示例中心
功能在线体验
控制台

高德 开发 Android 导航SDK 开发指南 创建工程 集成导航1.9.3-1.9.4版本必看

更新时间:2017年04月21日

导航需要不断的接收 GPS 定位信息,目前导航 SDK 中融入了定位 SDK 相关功能,借助定位 SDK 可提升导航效果。

您在升级导航 SDK 时可能会遇到问题,在此逐一为您列出解决方案:

冲突问题

若您升级了1.9.3和1.9.4版本的导航SDK,同时项目中配置了高德Android定位SDK,运行程序时会出现冲突错误。

解决方法:从您的项目中移除高德定位 SDK ,采用导航 SDK 携带的定位接口即可。

Android Studio中的错误如下图:

Eclipse中的错误如下图:

无法导航

若配置了高德 Key,手机也打开了 GPS 开关,但依旧无法定位,导航功能也无法正常使用。

解决方法:检查您的 AndroidManifest.xml 文件中是否声明 Service 组件。若没有配置,需按照以下代码在 application 标签中声明 service 组件。

<service android:name="com.amap.api.location.APSService"></service>

若您的项目中已经配置过 Service 组件,无需再次配置,一个 app 拥有自己单独的定位 service。

示例中心 功能
在线体验
常见问题